Thor's Hammer Programming Issue

Discussion in 'XBOX360 Legacy Tech Support' started by ecchick524, Feb 11, 2012.

  1. ecchick524

    ecchick524 New Member

    I just received my Thor's Hammer controller today and have an issue with keeping it in programming mode. I have followed all the instructions as in the videos and on the various documents, however the controller stays in programming mode for about 5 secs and then stops. My PC won't recognize it because it's not in the right mode when I go to connect it. (both LED's are flashing - but then stop after a few seconds - just defaults to one steady LED in slot 1). This is so frustrating because I really want to start setting up some speeds. I have changed the batteries - used brand new ones, also tried a fully charged battery pack and I'm still having an issue. Please advise! Is there something else I'm missing...???
     
  2. odingalt

    odingalt Well-Known Member Staff Member

    Greetings. Here are a few things to try:

    Side note, if you happen to press "Button a" or the "right thumbstick press" while programming or having your Thor's Hammer connected, it will disconnect. The reason is simple - the modchip was running low on pins, so we "Doubled up" - the USB port shares two pins with "button A" and "right thumbstick press". So be sure not to hit those two buttons or it'll disconnect.

    Also, your controller provides its own power during programming - it doesn't get power from the USB. So you have to make sure to have good batteries or the USB won't work. A dead play-and-charge pack will cause problems every time. Be sure to try a fresh set of AA alkalines. The gist is that USB will stop working if the battery voltage falls below 2.4 volts (which is what a dead play and charge pack does) and could even potentially have issues down around 2.6 volts (dead AA's) depending on the computer/laptop.

    Last thing you might try a different USB port on the computer. Some cheap USB hubs or powered USB hubs do not comply with the USB specification. I've seen where the front ports on the PC don't work andn vice-veras where the back ports caused people problems. So it's always worth trying the opposite side of your computer/laptopt's USB port.

    Also please tell me you are not running Windows on a Mac by using virtual windows, vmware, bootcamp or something like that. You need a bona-fide Windows PC.
     
  3. ecchick524

    ecchick524 New Member

    Thank you for replying....I am using a Windows laptop running Win 7. The laptop is seeing the controller when connected because the drivers are being installed for the "Microsoft Xbox Play and Charge Kit". Is this causing the issue? I've tried the synching/programming on another desktop computer running Vista - and the same thing is happening. The flashing software is not recognizing the controller - saying its not in bootloader mode.

    I'm very careful about pressing only the sync button and the power on button - not touching A or the right thumbstick. For process of elimination, I'm going to get brand new spanking batteries and try the other cable instead of the PnC cable.

    One question - when the controller is in programming mode, should the player 1 and player 2 LEDs continuously blink? On mine, they blink for about 3-5 secs, stop and the player 1 led stays lit.
     
    Last edited: Feb 11, 2012
  4. ecchick524

    ecchick524 New Member

    Update! Ok, I figured out the problem...I had to uninstall the Xbox 360 Play and Charge Kit drivers and NOT use that cable. I'm using the cable provided by Viking - once it connected, the bootloader drivers installed and it connected to the flashing software with no issue. Yay! :)
     
  5. odingalt

    odingalt Well-Known Member Staff Member

    Correct, if you have a 3.5mm jack hole in the back of your Thor's Hammer, you have to use the 3.5mm-to-USB programming cable (included).

    There are some models of Thor's Hammer that have no 3.5mm-to-USB jack, on these models you would use the play-and-charge cable to do the programming of the modchip.
     

Share This Page